Service Unavailable - Plex over BT

Incident Report for Matt's Services

Resolved

Services are showing as online and available.

You may need to restart any applications which were using this link.
Posted Aug 16, 2025 - 23:33 UTC

Identified

We're experiencing connectivity issues to Plex over the BT link, and are currently looking into the issue.
Posted Aug 16, 2025 - 22:22 UTC
This incident affected: Plex Services (Plex - BT).